Paradox Community

Items in pnews.paradox-discussions

Subject:Re: Mapped Drives Pdox9
Date:Mon, 4 Sep 2017 22:19:30 +1000
From:"Leslie" <ViaThe>
"John Wright" <> wrote in message
> On 04/09/2017 12:07, John Wright wrote:
>> On 04/09/2017 11:38, Leslie wrote:
>>> "John Wright" <> wrote in message
>>>> On 04/09/2017 00:37, Leslie wrote:
>>>>> "John Wright" <> wrote in message
>>>>> news:59ac16b0$
>>>>>> I have needed to reinstall Paradox 9 Developers Addition on a Windows

>>>>>> 10
>>>>>> 64bit machine and everything is fine EXCEPT that I cannot see the two
>>>>>> mapped drives that are pre-set when trying to set up the required 
>>>>>> Alias!
>>>>>> Aliases on the folders on the machine are fine. I can see all other
>>>>>> folders
>>>>>> on the machine and the network - just the two Mapped drives X: and
>>>>>> are
>>>>>> not there. I have tried deleting the Aliases and remaking them but
>>>>>> luck.
>>>>>> These Aliases were working fine on the previous installation on the

>>>>>> same
>>>>>> machine. Any ideas why this should be please?
>>>>> Perhaps the mapped drives were created in a user account and when 
>>>>> running
>>>>> it
>>>>> elevates to an admin account.
>>>>> Try this: whilst it is running and you cannot "see" the mapped drives,
>>>>> open
>>>>> a command prompt and type net use, this will list the available 
>>>>> drives.
>>>>> Leslie.
>>>> Thanks Leslie.
>>>> I have opened Paradox and I have used the Cmd etc. and it shows the 
>>>> Mapped
>>>> Drives are there and marks them as 'ok'. They come under my Users area 
>>>> on
>>>> the machine? The Mapped Drives are though showing as running in the 
>>>> root
>>>> 'C:\' drive itself so I'm not sure how to change what is reported! Any
>>>> further suggestions please?
>>>> Sorry... I should not say in the 'C:\' drive of course, it is under the
>>>> root (This PC) in the machine of course!
>>> Try opening the command prompt as admin and then type net use. if it 
>>> says
>>> the mapped drives are unavailable then they do not exist im elevated
>>> account.
>>> Of this is assuming that the program is being launched elevated (or as
>>> admin).
>>> Leslie.
>> Thanks again Leslie,
>> When Comand Prompt is opened as Run as Administrator it reports blank to 
>> the command 'net use'. So does this indicate that Paradox cannot see the 
>> Mapped Drives? Why would that have changed in my having reinstalled 
>> Paradox I wonder?
>> John
> Leslie,
> Thanks for your help on this. It looks likes I have solved the issue by 
> changing the Registry to allow EnableLinkedConnections in the area of 
> 32bit Windows System area of the Registry.
> I found the following by a Google Search...
> ---------------
>     Click Start, type regedit in the Start programs and files box, and 
> then press ENTER.
>     Locate and then right-click the registry subkey 
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.
>     Point to New, and then click DWORD Value.
>     Type EnableLinkedConnections, and then press ENTER.
>     Right-click EnableLinkedConnections, and then click Modify.
>     In the Value data box, type 1, and then click OK.
>     Exit Registry Editor, and then restart the computer.
> -----------
> I am most grateful for your prompt response that pointed me in the right 
> direction.
> John

I am already aware of this registry setting and I am glad it is working for 
you but for the record I hate these sort of hacks.

The fact that you need this at all confirms Paradox is running elevated. 
Really it should not be and **that** is the real issue.


Copyright © 2004