Paradox Community

Items in pnews.paradox-interactive

Subject:Re: Pdox9
Date:Tue, 4 Dec 2018 07:53:12 -0600
From:Mark Bannister <>
Delete all the lock files in all directories and sub-directories, 
private and anywhere database tables are found.  These include 
PARADOX.LCK and PDOXUSRS.LCK as well as PDOXUSRS.NET.  It is most likely 
a local lock file in the private directory.

On 12/4/2018 5:19 AM, Ivan wrote:
> Hi there
> I've a strange problem with Pdox9 on Win10
> It work fine for a long time.
> Today something happened, and I don't know what.
> OK there was a problem with an app which I develop and I've to stop it 
> with Ctrl+Alt+Delete (what I did earlier many times without problems).
> After that, if I want to start P9, I allways get teh following message:
>     Could not initialize BDE:
>     You have attempted to open a database that is in use by
>     someone else, but the database cannot be share. You must
>     set the location for the .NET control file
> I think - ok, something happened as many times before. But:
> - Pdox9 Runtime works fine
> - the NET DIR path in BDE 5.01 is OK.
> - if I delete the PDOXUSRS.NET file and restart P9, I get the same 
> message and a new PDOXUSRS.NET appers within the NET DIR path
> - I've deleted all PDOXUSRS.NET files on the whole PC (all 
> partitions)    - the same BDE message
> - I've reinstalled the whole BDE (delete first the CONFIG01 and DLLPATH 
> registry entries)    - nothing changed (same BDE mesasage)
> - I've reinstalled the whole P9 (from an earlier CD copy on the disk, 
> because the CD can't be read any more)    - nothing changed (same BDE 
> message)
> - I've the P9 installed on an another PC with Win7, it works ok. So I've 
> copied the whole Corel directory from Win7 to Win10 - nothing changed 
> (same BDE message)
> - I looked to the quarantine of the AntiVirus program. There's nothing 
> from today or earlier from Corel path
> - I've restarted the PC many times (after each change)    - the same BDE 
> message
> - I've renamed the directory, where I've worked last time with P9    - 
> got first message about invalid path, but after that the same BDE message
> - After the shutdown, there were first some messages like: I tried to 
> read a string after it's end (or similar). But they disappeared and came 
> not again.
> I've no idea, what's going wrong and how to repair it - I hope, it's 
> something small (because P9R works ok).
> Should I try to set the Win10 to an earlier state? I get the Win10 
> warning, that if I do it, I've to reinstall the Corel Application - and 
> I don't like such experiments (but if necessary, I'll do it).
> Thanks for any hints
> Ivan
> ---
> Diese E-Mail wurde von AVG auf Viren geprüft.

Copyright © 2004